挺简单的,多占内存,少用循环
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:5 30 0 255 16777215 2424 24 0 0 2424 0 24 24 24Sample Output:
24
#pragma warning(disable:4996)
#include <stdio.h>
using namespace std;
int a[16777216];
int main(void) {
int m, n;
scanf("%d %d", &m, &n);
int p = m*n,temp,count=0,result=0;
for (int i = 0; i < p; i++) {
scanf("%d", &temp);
a[temp]++;
if (a[temp] > count) {
count = a[temp];
result = temp;
}
}
printf("%d", result);
return 0;
}